<!DOCTYPE html>
<html class="root root_js_disabled" lang="en-US" data-version="2.6.2.1" data-platform="desktop">
<head>
    <meta charset="utf-8" />
    <title>St. Pete native Will Packer co-producing this year&#x27;s Oscars | wtsp.com</title>
    <script>!function(){window.performance.mark("tegna_server_response");var n=new URLSearchParams(window.location.search).get("otConsentString");if(n){document.cookie=`OptanonAlertBoxClosed=${(new Date).toISOString()}`;let e=new Date;e.setYear(e.getFullYear()+1),e=e.toISOString();var t=(new Date).toString().replace(/\ /g,"+").replace(/:/g,"%3A");document.cookie=`OptanonConsent=datestamp=${t}&version=6.0.0&interactionCount=0&isIABGlobal=false&landingPath=NotLandingPage&groups=${encodeURIComponent(n)}&hosts=&legInt=; expires=${e}`}}(),window.tegna=window.tegna||{},window.tegna.supportsJavascript="noModule"in document.createElement("script"),window.tegna.supportsJavascript?(document.documentElement.classList.remove("root_js_disabled"),window.tegna.performance={received:{time:window.performance.now()}},window.tegna.ie=!!window.MSInputMethodContext&&!!document.documentMode):document.documentElement.classList.add("root_ie_true");
//# sourceMappingURL=immediate.js.map</script>
    <style>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</style>
    <style>:root {
    --theme-primary: #045ea8;
    --theme-secondary: #045ea8;
}</style>

<link rel="preload" href="/modules.min_6.2.1.css" as="style" onload="this.onload=null;this.rel='stylesheet';window.tegna.performance.painted = { 'time': window.performance.now() };window.performance.mark('tegna_styled');" />
<noscript><link rel="stylesheet" href="/modules.min_6.2.1.css"></noscript>

<link rel="preload" href="/common.min_6.2.1.js" as="script" type="text/javascript" />

    <link rel="preconnect" href="//media.wbir.com">
    <link rel="preconnect" href="//interactive.wbir.com">
    <link rel="preconnect" href="//tgna-ux-dev.service.signalr.net">
    <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    <link rel="preconnect" href="//www.google.com">
    <link rel="preconnect" href="//adservice.google.com">
    <link rel="preconnect" href="//tpc.googlesyndication.com">
    <link rel="preconnect" href="//cdn.ampproject.org">
    <link rel="preconnect" href="//pagead2.googlesyndication.com">
    <link rel="preconnect" href="//www.gstatic.com">
    <link rel="icon" href="/assets/favicons/WTSP.png?ver=2.6.2.1" />
    <link rel="canonical" href="https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c" />
            <meta name="theme-color" content="#045ea8" />
            <link rel="amphtml" href="https://www.wtsp.com/amp/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c" />
        <meta itemprop="datePublished" content="11:17 PM EDT March 26, 2022" />
        <meta itemprop="dateModified" content="11:43 PM EDT March 26, 2022" />
        <meta itemprop="url" content="https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c" />
        <meta itemprop="magnet:custom" name="category" content="news" />
        <meta property="og:url" content="https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c">
        <meta property="og:title" content="From Tampa Bay to Hollywood: South St. Pete native Will Packer producing Sunday&#x2019;s Oscars">
        <meta property="og:description" content="Known for films like Girls Trip and Straight Outta Compton, the St. Pete High School graduate will be one half of the Oscars&#x2019; first all-Black producing team.">
        <meta property="og:type" content="article" />
        <meta property="og:image" content="https://media.wtsp.com/assets/WTSP/images/ab7c995f-f96b-476d-8ea9-48b4c14b577b/ab7c995f-f96b-476d-8ea9-48b4c14b577b_1140x641.jpg">
        <meta property="og:image:width" content="1140" />
        <meta property="og:image:height" content="641" />
        <meta property="og:article:published_time" content="11:17 PM EDT March 26, 2022" />
        <meta property="article:opinion" content="false" />
        <meta property="article:content_tier" content="free">
        <meta property="article:section" content="wtsp,news,entertainment-news,nation-world" />
        <meta name="twitter:title" content="From Tampa Bay to Hollywood: South St. Pete native Will Packer producing Sunday&#x2019;s Oscars">
        <meta name="twitter:image:src" content="https://media.wtsp.com/assets/WTSP/images/ab7c995f-f96b-476d-8ea9-48b4c14b577b/ab7c995f-f96b-476d-8ea9-48b4c14b577b_1140x641.jpg">
        <meta name="twitter:image" content="https://media.wtsp.com/assets/WTSP/images/ab7c995f-f96b-476d-8ea9-48b4c14b577b/ab7c995f-f96b-476d-8ea9-48b4c14b577b_1140x641.jpg">
        <meta name="twitter:card" content="summary_large_image">
        <meta name="twitter:site" content="10TampaBay">
        <meta name="twitter:description" content="Known for films like Girls Trip and Straight Outta Compton, the St. Pete High School graduate will be one half of the Oscars&#x2019; first all-Black producing team.">
        <meta name="twitter:domain" content="www.wtsp.com">


            <meta name="viewport" content="width=1170" />
            <meta name="site" content="wtsp.com" />
            <meta name="description" content="Will Packer, a south St. Petersburg, Florida, native is making history as he produces the 94th Academy Awards on March 27." />
            <meta property="fb:app_id" content="1997344770552980" />
            <meta property="og:site_name" content="wtsp.com" />
            <meta property="og:locale" content="en_US" />
            <meta itemprop="pageType" content="article" />
            <meta itemprop="datePublished" content="11:17 PM EDT March 26, 2022" />
    <script>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</script>
        <!-- OneTrust Cookies Consent Notice start -->
        <script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="c173c35a-536b-4ab0-8adc-f558ba869259"></script>
        <script type="text/javascript">function OptanonWrapper() { }</script>
        <!-- OneTrust Cookies Consent Notice end -->
        <script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0004,C0002" ccpa-opt-out-geo="all" ccpa-opt-out-lspa="true"></script>
<!-- utag_data -->
<script id="utag_data_script" data-visit-event-name="pageView" data-current-site-id="67" data-watson-keywords="South St. Pete,Tampa Bay,St. Pete High School graduate,native Will Packer,Tampa Bay&#x2019;s Emerald Morrow" data-page-type="article" data-gpt-network-code="32805352/fl-tampa-WTSP-B3313_DesktopTablet" data-section="news" data-subsection="entertainment-news" data-topic="" data-subtopic="" data-content-type="article" data-category="news" data-market="Tampa, FL" data-subcategory="entertainment-news" data-keywords="Tampa, Tampa Bay, Sarasota, FL, news, local news, breaking news, traffic, weather, sports, events10NEWS" data-document-title="Tampa Bay and Sarasota&#x27;s Leading Local News: Weather, Traffic, Sports and more | Tampa Bay and Sarasota, FL | WTSP.com" data-ga-property-id="UA-74514132-1" data-division="broadcast" data-site-type="desktop" data-page-url="https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c" data-canonical-url="https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c" data-asset-id="60112934-7fa9-4fff-a304-8668bfd4b11c" data-article-keywords="entertainment-news,news,nation-world,home" data-content-title="From Tampa Bay to Hollywood: South St. Pete native Will Packer producing Sunday&#x2019;s Oscars" data-content-categories="entertainment-news,news,nation-world,home" data-content-score="85" data-tracking-tags="" data-t1-publisher="jhighsmith@tegna.com" data-call-letters="WTSP" data-article-byline="Emerald Morrow" data-topics-included="false" data-video-included="true" data-video-autoplay="true" data-video-title="From Tampa Bay to Hollywood: South St. Pete native Will Packer producing Sunday&#x2019;s Oscars" data-video-name="From Tampa Bay to Hollywood: South St. Pete native Will Packer producing Sunday&#x2019;s Oscars" data-video-length="0" data-video-related-play="false" data-item-number="1" data-original-headline="From Tampa Bay to Hollywood: South St. Pete native Will Packer producing Sunday&#x2019;s Oscars" data-cct-story="false" data-platform="desktop" data-full-environment="WTSP" data-index-wrapper-url="//js-sec.indexww.com/ht/p/184603-155416222999223.js" data-a9-publisher-id="3276" data-a9-timeout="1000" data-pubmatic-desktop-url="https://ads.pubmatic.com/AdServer/js/pwt/160138/4037/pwt.js" data-pubmatic-mobile-url="https://ads.pubmatic.com/AdServer/js/pwt/160138/4038/pwt.js">!function(){var e;window.tegna.supportsJavascript&&(e=document.getElementById("utag_data_script").dataset,window.tegna.initialTracking={visit_event_name:e.visitEventName,current_site_id:e.currentSiteId,watson_keywords:e.watsonKeywords,template_type:"",page_type:e.pageType,division:e.division,site_type:e.siteType,page_url:e.pageUrl,gpt_network_code:e.gptNetworkCode,section:e.section,subsection:e.subsection,topic:e.topic,subtopic:e.subtopic,content_type:e.contentType,category:e.category,market:e.market,subcategory:e.subcategory,keywords:e.keywords,document_title:e.documentTitle,ga_property_id:e.gaPropertyId,canonical_url:e.canonicalUrl,video_included:e.videoIncluded,video_name:e.videoName,video_length:e.videoLength,video_related_play:e.videoRelatedPlay,article_date:e.articleDate,asset_id:e.assetId,article_keywords:e.articleKeywords,content_title:e.contentTitle,original_headline:e.originalHeadline,content_categories:e.contentCategories,tracking_tags:e.trackingTags,t1_publisher:e.t1Publisher,article_byline:e.articleByline,topics_included:e.topicsIncluded,call_letters:e.callLetters,item_number:e.itemNumber,content_score:e.contentScore,cct_story:e.cctStory,platform:e.platform,full_environment:e.fullEnvironment,index_wrapper_url:e.indexWrapperUrl,a9_publisher_id:e.a9PublisherId,a9_timeout:e.a9Timeout,pubmatic_desktop_url:e.pubmaticDesktopUrl,pubmatic_mobile_url:e.pubmaticMobileUrl},window.utag_data=JSON.parse(JSON.stringify(window.tegna.initialTracking)))}();
//# sourceMappingURL=utag-data.js.map</script>
        <script src="https://www.google.com/recaptcha/api.js?onload=recaptchaCallback&render=explicit" async defer></script>
        <script type="text/javascript">var recaptchaCallback = function () {
                window.grecaptcha = grecaptcha;
                console.log('recaptcha is ready');
            }</script>
    <style>
        .root_ie_true template {
            display: none;
        }
        #onetrust-consent-sdk #onetrust-pc-sdk .pc-header {
            position: relative;
        }
        #onetrust-consent-sdk #onetrust-pc-sdk .pc-logo {
            background-image: url('/assets/shared-images/logos/wtsp.png') !important;
        }
    </style>
    <script type="text/javascript" data-taboola-type="article">window._taboola = window._taboola || [];
        let obj = {};
        obj[document.currentScript.dataset.taboolaType] = 'auto';
        _taboola.push(obj);</script>
    <!-- head content below this is dynamically added -->
</head>
<body>
    <script>if(window.tegna.supportsJavascript){window.tegna.addScript=e=>{var t=document.createElement("script");t.src=e,document.head.appendChild(t)},window.tegna.log=function(e,t,i,n){var o=(o=20-e.length)<0?0:o,a=(a=30-t.length)<0?0:a,r="log";"error"in console&&3===n?r="error":"warn"in console&&2===n?r="warn":"info"in console&&(r="info");a="["+e+"] "+" ".repeat(o)+t+" ".repeat(a);i?void 0:void 0},window.tegna.loadModule=function(e,i){var n=e.parentNode,o=n.querySelectorAll(".grid__template")[0];"undefined"!=typeof templatePolyfill&&templatePolyfill(n);var a=document.importNode(o.content,!0),t="IntersectionObserver"in window&&"IntersectionObserverEntry"in window;e.remove(),t?new window.IntersectionObserver(function(e,t){e.forEach(function(e){if(e.isIntersecting){o.remove(),n.append(a),n.closest(".grid__module").classList.add("grid__module_loaded_true"),n.closest(".grid__module").classList.remove("grid__module_loaded_false"),t.unobserve(n),"undefined"!=typeof require&&require([i]),"$"in window&&$(window).trigger("tegnaBroadcast",["grid","addedSection",{$el:$(n),el:n}]);let e={el:n};"$"in window&&(e.$el=$(n)),window.dispatchEvent(new CustomEvent("tegnaBroadcastNoJQ",{detail:{source:"grid",action:"addedSection",data:e}}))}})}).observe(n):(o.remove(),n.append(a))};class e extends HTMLElement{get os(){return this.getAttribute("os")}set os(e){this.setAttribute("os",e)}set active(e){e?(this.setAttribute("aria-hidden","false"),this.setAttribute("active","")):(this.setAttribute("aria-hidden","true"),this.removeAttribute("active"))}constructor(){super()}connectedCallback(){var e=navigator.userAgent||navigator.vendor||window.opera;let t="unknown";/android/i.test(e)&&(t="android"),/iPad|iPhone|iPod/.test(e)&&!window.MSStream&&(t="ios"),t===this.os.toLowerCase()?this.active=!0:this.active=!1}}window.customElements.define("tegna-sniff",e);class t extends HTMLElement{get uuid(){return this.getAttribute("uuid")}set uuid(e){this.setAttribute("uuid",e)}set active(e){e?(this.setAttribute("aria-hidden","false"),this.setAttribute("active","")):(this.setAttribute("aria-hidden","true"),this.removeAttribute("active"))}constructor(){super()}}window.customElements.define("tegna-variant",t);class i extends HTMLElement{get uuid(){return this.getAttribute("uuid")}set uuid(e){this.setAttribute("uuid",e)}constructor(){super()}connectedCallback(){window.setTimeout(()=>{let t=[...this.children],a=t[0].uuid;var e=window.localStorage.getItem(this.uuid);null!==e?(a=e,window.tegna.log("_abtest","showingStoredVariant",{test:this.uuid,variant:e})):(a=t[e=t.length,Math.floor(Math.random()*Math.floor(e))].uuid,window.localStorage.setItem(this.uuid,a),window.localStorage.setItem(`${this.uuid}_tegna_expire`,Date.now()+108e5),window.tegna.log("_abtest","showingNewVariant",{test:this.uuid,variant:a}));const i=async(e,t,i)=>{var n=document.querySelector(".page").dataset.uxTrackingUrl;const o=await fetch(n,{method:"POST",headers:{"Content-Type":"application/json",pragma:"no-cache","cache-control":"no-cache"},body:JSON.stringify({testId:this.uuid,siteId:document.querySelector(".page").dataset.siteId,variantId:a,click:e?1:0,impression:t?1:0})});o.text().then(e=>{i(e)})};for(var n=0;n<t.length;n++)if(t[n].uuid===a){t[n].active=!0,[...t[n].querySelectorAll("a:not([data-ab-click-mode=ignore])")].forEach((t,e)=>{t.addEventListener("click",e=>{e.preventDefault(),e.stopPropagation(),i(!0,!1,()=>{window.location=t.getAttribute("href")}),window.setTimeout(()=>{window.location=t.getAttribute("href")},500)})});let e=new IntersectionObserver((e,t)=>{e.forEach(e=>{e.isIntersecting?(window.tegna.log("_abtest","attemptingImpression",{el:this,test:this.uuid,variant:a}),i(!1,!0,()=>{window.tegna.log("_abtest","impression",{el:this,test:this.uuid,variant:a})}),t.unobserve(e.target)):window.tegna.log("_abtest","notIntersecting")})});e.observe(this)}else t[n].active=!1})}}window.customElements.define("tegna-ab",i)}
//# sourceMappingURL=above-page-scripts.js.map</script>
    <div data-module="page" data-state="ready" class="page"
         data-embed="false"
         data-platform="desktop"
         data-page-type="article"
         data-ux-tracking-url="https://abtesting.tegnadigital.com/api/SendUxAbTestingData?code=Q5WXSaZBgX62yZXBNCEkW14/TWYAS4svWB3HEDszID8vZq2Gg5QFfQ=="
         data-api-key=""
         data-environment="Production"
         data-is-monitor="false"
         data-is-preview="false"
         data-site-id="67"
         data-primarydomain="wtsp.com"
         data-environment-base-url="https://www.wtsp.com/"
         data-call-letters="WTSP"
         data-full-environment="WTSP"
         data-twitter-id="10TampaBay"
         data-fban="1997344770552980"
         data-refresh="420"
         data-dfpid="32805352"
         data-comscoreid="19962895"
         data-recaptchasitekey="6LdhZY8UAAAAANQxx8Y6_JJZSJtONlMiM_yiKTah"
         data-targeting-video_included="true"
         data-targeting-ttid="60112934-7fa9-4fff-a304-8668bfd4b11c"
         data-targeting-pgtype="article"
         data-targeting-topic_section=""
         data-targeting-url="https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c"
         data-is-video="false"
         data-is-longform="false"
         data-gptid="fl-tampa-WTSP-B3313_DesktopTablet"
         data-tealium-url="//tags.tiqcdn.com/utag/tegna/wtsp-redesign-desktop/prod/utag"
         data-taboola-url="https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c"
         data-elvs-id=""
         data-elvs-stream-url=""
         data-is-elvs-disabled="true"
         data-tealium-id-comscore="1"data-tealium-id-datasphere="457"data-tealium-id-dealboss="538"data-tealium-id-googleanalytics="467"data-tealium-id-oneplusx="560"data-tealium-id-simplifi="541"data-tealium-id-taboola="540"data-tealium-id-truanthem="442"data-tealium-id-visto="456"         >
            <div class="page__top">

    <div class="universal-ad" data-module="universal-ad">
        <div class="universal-ad__close-button">
            <img src="/assets/shared-images/icons/close-menu.svg" alt="x" width="14" height="14" />
        </div>
        <div class="universal-ad__ad">
        <div data-module="ad" class="ad ad_position_article_universal ad_background_true"
         data-status="new"
         data-path="/32805352/fl-tampa-WTSP-B3313_DesktopTablet/article_universal/news/entertainment-news"
         data-sizes="[[1140,250],[970,250],[728,90],[1,1]]"
         data-delay="0"
         data-position="article_universal"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id="1420432758"
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id="4204204272"
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
    </div>
            </div>
            <div class="page__header">
<header data-module="header" class="header"
        data-alerts="true"
        data-facebook-app-id="1997344770552980"
        data-twitter-id="10TampaBay">
    <a class="header__skip" href="#main" tabindex="1">Skip Navigation</a>
    <div class="header__main">
        <ul class="header__social-list">
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_facebook" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="facebook">Share on Facebook</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_twitter" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="twitter">Share on Twitter</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_sms" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="sms">Share on SMS</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_email" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="email">Share on Email</a>
            </li>
        </ul>
        <div class="header__main-inner">
            <div class="header__hamburger">
                <div class="header__hamburger-icon-container">
                    <div class="header__hamburger-icon"></div>
                </div>
            </div>
            <a class="header__station-branding" href="/" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="masthead-logo">
                <img class="header__logo" alt="Home" src="/assets/shared-images/logos/wtsp.png" loading="eager" width="112" onload="this.parentElement.style.opacity='1';" />
            </a>
            <nav class="header__not-logo">
                <h2 class="header__nav-heading">Navigation</h2>
                <div class="header__tooltip-overlay"></div>
                <ul class="header__nav">
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/news" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="News">
                                        <span class="header__nav-label">News</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/local" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Local">
                                                                    <span class="header__subnav-label">Local</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/sports" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Sports">
                                                                    <span class="header__subnav-label">Sports</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/florida-news" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Florida">
                                                                    <span class="header__subnav-label">Florida</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/10-investigates" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="10Investigates">
                                                                    <span class="header__subnav-label">10Investigates</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/nation-world" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Nation World">
                                                                    <span class="header__subnav-label">Nation World</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/brightside" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Brightside">
                                                                    <span class="header__subnav-label">Brightside</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/nightside" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Nightside">
                                                                    <span class="header__subnav-label">Nightside</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/politics" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Politics">
                                                                    <span class="header__subnav-label">Politics</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/money" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Money">
                                                                    <span class="header__subnav-label">Money</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/entertainment" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Entertainment">
                                                                    <span class="header__subnav-label">Entertainment</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/features" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Features">
                                                                    <span class="header__subnav-label">Features</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest News Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/article/news/local/tampa-pride-diversity-parade/67-82426c02-8f1b-404a-9c80-c15a3ec1a7ff" aria-label="Read Tampa Pride &#x27;Diversity Parade&#x27; attendees say the celebration is about love and acceptance" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Tampa Pride &#x27;Diversity Parade&#x27; attendees say the celebration is about love and acceptance">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Tampa Pride 'Diversity Parade' attendees say the celebration is about love and acceptance" width="" height="" src="https://media.wtsp.com/assets/WTSP/images/b3d604c1-61ad-4f57-b05d-2b86e02878bc/b3d604c1-61ad-4f57-b05d-2b86e02878bc_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Tampa Pride 'Diversity Parade' attendees say the celebration is about love and acceptance" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wtsp.com/assets/WTSP/images/b3d604c1-61ad-4f57-b05d-2b86e02878bc/b3d604c1-61ad-4f57-b05d-2b86e02878bc_360x203.jpg" data-srcset="https://media.wtsp.com/assets/WTSP/images/b3d604c1-61ad-4f57-b05d-2b86e02878bc/b3d604c1-61ad-4f57-b05d-2b86e02878bc_16x9.jpg 16w, https://media.wtsp.com/assets/WTSP/images/b3d604c1-61ad-4f57-b05d-2b86e02878bc/b3d604c1-61ad-4f57-b05d-2b86e02878bc_140x79.jpg 140w, https://media.wtsp.com/assets/WTSP/images/b3d604c1-61ad-4f57-b05d-2b86e02878bc/b3d604c1-61ad-4f57-b05d-2b86e02878bc_360x203.jpg 360w, https://media.wtsp.com/assets/WTSP/images/b3d604c1-61ad-4f57-b05d-2b86e02878bc/b3d604c1-61ad-4f57-b05d-2b86e02878bc_540x304.jpg 540w, https://media.wtsp.com/assets/WTSP/images/b3d604c1-61ad-4f57-b05d-2b86e02878bc/b3d604c1-61ad-4f57-b05d-2b86e02878bc_750x422.jpg 750w, https://media.wtsp.com/assets/WTSP/images/b3d604c1-61ad-4f57-b05d-2b86e02878bc/b3d604c1-61ad-4f57-b05d-2b86e02878bc_1140x641.jpg 1140w, https://media.wtsp.com/assets/WTSP/images/b3d604c1-61ad-4f57-b05d-2b86e02878bc/b3d604c1-61ad-4f57-b05d-2b86e02878bc_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/local/tampa-pride-diversity-parade/67-82426c02-8f1b-404a-9c80-c15a3ec1a7ff" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Tampa Pride &#x27;Diversity Parade&#x27; attendees say the celebration is about love and acceptance">Tampa Pride &#x27;Diversity Parade&#x27; attendees say the celebration is about love and acceptance</a></h4>
                                            </div>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/video/news/local/south-st-pete-native-will-packer-producing-sundays-oscars/67-b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4" aria-label="Read South St. Pete native Will Packer producing Sunday&#x2019;s Oscars" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; South St. Pete native Will Packer producing Sunday&#x2019;s Oscars">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="South St. Pete native Will Packer producing Sunday’s Oscars" width="" height="" src="https://media.wtsp.com/assets/WTSP/images/d114c68c-8bcf-4f3d-8c79-f4126172e41a/d114c68c-8bcf-4f3d-8c79-f4126172e41a_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="South St. Pete native Will Packer producing Sunday’s Oscars" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wtsp.com/assets/WTSP/images/d114c68c-8bcf-4f3d-8c79-f4126172e41a/d114c68c-8bcf-4f3d-8c79-f4126172e41a_360x203.jpg" data-srcset="https://media.wtsp.com/assets/WTSP/images/d114c68c-8bcf-4f3d-8c79-f4126172e41a/d114c68c-8bcf-4f3d-8c79-f4126172e41a_16x9.jpg 16w, https://media.wtsp.com/assets/WTSP/images/d114c68c-8bcf-4f3d-8c79-f4126172e41a/d114c68c-8bcf-4f3d-8c79-f4126172e41a_140x79.jpg 140w, https://media.wtsp.com/assets/WTSP/images/d114c68c-8bcf-4f3d-8c79-f4126172e41a/d114c68c-8bcf-4f3d-8c79-f4126172e41a_360x203.jpg 360w, https://media.wtsp.com/assets/WTSP/images/d114c68c-8bcf-4f3d-8c79-f4126172e41a/d114c68c-8bcf-4f3d-8c79-f4126172e41a_540x304.jpg 540w, https://media.wtsp.com/assets/WTSP/images/d114c68c-8bcf-4f3d-8c79-f4126172e41a/d114c68c-8bcf-4f3d-8c79-f4126172e41a_750x422.jpg 750w, https://media.wtsp.com/assets/WTSP/images/d114c68c-8bcf-4f3d-8c79-f4126172e41a/d114c68c-8bcf-4f3d-8c79-f4126172e41a_1140x641.jpg 1140w, https://media.wtsp.com/assets/WTSP/images/d114c68c-8bcf-4f3d-8c79-f4126172e41a/d114c68c-8bcf-4f3d-8c79-f4126172e41a_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/video/news/local/south-st-pete-native-will-packer-producing-sundays-oscars/67-b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; South St. Pete native Will Packer producing Sunday&#x2019;s Oscars">South St. Pete native Will Packer producing Sunday&#x2019;s Oscars</a></h4>
                                            </div>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/weather/" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Weather">
                                        <span class="header__nav-label">Weather</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/forecast" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Forecast">
                                                                    <span class="header__subnav-label">Forecast</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/radar" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Radar">
                                                                    <span class="header__subnav-label">Radar</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/10-day" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="10-Day &amp; Hourly">
                                                                    <span class="header__subnav-label">10-Day &amp; Hourly</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/tropics" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Hurricane Headquarters">
                                                                    <span class="header__subnav-label">Hurricane Headquarters</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/weather-cams" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Weather Cameras">
                                                                    <span class="header__subnav-label">Weather Cameras</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/traffic" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Traffic">
                                                                    <span class="header__subnav-label">Traffic</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/weatherexplainers" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Weather Explainers">
                                                                    <span class="header__subnav-label">Weather Explainers</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest Weather Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/article/weather/weather-forecast-wtsp/67-489786259" aria-label="Read 10 Weather: Sunshine and 70s for Sunday" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; 10 Weather: Sunshine and 70s for Sunday">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="10 Weather: Sunshine and 70s for Sunday" width="" height="" src="https://media.wtsp.com/assets/WTSP/images/bed6b1f9-d20d-448f-8434-c50c7c152552/bed6b1f9-d20d-448f-8434-c50c7c152552_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="10 Weather: Sunshine and 70s for Sunday" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wtsp.com/assets/WTSP/images/bed6b1f9-d20d-448f-8434-c50c7c152552/bed6b1f9-d20d-448f-8434-c50c7c152552_360x203.jpg" data-srcset="https://media.wtsp.com/assets/WTSP/images/bed6b1f9-d20d-448f-8434-c50c7c152552/bed6b1f9-d20d-448f-8434-c50c7c152552_16x9.jpg 16w, https://media.wtsp.com/assets/WTSP/images/bed6b1f9-d20d-448f-8434-c50c7c152552/bed6b1f9-d20d-448f-8434-c50c7c152552_140x79.jpg 140w, https://media.wtsp.com/assets/WTSP/images/bed6b1f9-d20d-448f-8434-c50c7c152552/bed6b1f9-d20d-448f-8434-c50c7c152552_360x203.jpg 360w, https://media.wtsp.com/assets/WTSP/images/bed6b1f9-d20d-448f-8434-c50c7c152552/bed6b1f9-d20d-448f-8434-c50c7c152552_540x304.jpg 540w, https://media.wtsp.com/assets/WTSP/images/bed6b1f9-d20d-448f-8434-c50c7c152552/bed6b1f9-d20d-448f-8434-c50c7c152552_750x422.jpg 750w, https://media.wtsp.com/assets/WTSP/images/bed6b1f9-d20d-448f-8434-c50c7c152552/bed6b1f9-d20d-448f-8434-c50c7c152552_1140x641.jpg 1140w, https://media.wtsp.com/assets/WTSP/images/bed6b1f9-d20d-448f-8434-c50c7c152552/bed6b1f9-d20d-448f-8434-c50c7c152552_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/weather/weather-forecast-wtsp/67-489786259" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; 10 Weather: Sunshine and 70s for Sunday">10 Weather: Sunshine and 70s for Sunday</a></h4>
                                            </div>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/video/weather/10-weather-sunshine-and-70s-for-sunday/67-f493e88b-c767-4c9d-aca1-3786ee5e0363" aria-label="Read 10 Weather: Sunshine and 70s for Sunday" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; 10 Weather: Sunshine and 70s for Sunday">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="10 Weather: Sunshine and 70s for Sunday" width="" height="" src="https://media.wtsp.com/assets/WTSP/images/7071e302-8d5a-4127-8d4d-55e9bce61444/7071e302-8d5a-4127-8d4d-55e9bce61444_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="10 Weather: Sunshine and 70s for Sunday" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wtsp.com/assets/WTSP/images/7071e302-8d5a-4127-8d4d-55e9bce61444/7071e302-8d5a-4127-8d4d-55e9bce61444_360x203.jpg" data-srcset="https://media.wtsp.com/assets/WTSP/images/7071e302-8d5a-4127-8d4d-55e9bce61444/7071e302-8d5a-4127-8d4d-55e9bce61444_16x9.jpg 16w, https://media.wtsp.com/assets/WTSP/images/7071e302-8d5a-4127-8d4d-55e9bce61444/7071e302-8d5a-4127-8d4d-55e9bce61444_140x79.jpg 140w, https://media.wtsp.com/assets/WTSP/images/7071e302-8d5a-4127-8d4d-55e9bce61444/7071e302-8d5a-4127-8d4d-55e9bce61444_360x203.jpg 360w, https://media.wtsp.com/assets/WTSP/images/7071e302-8d5a-4127-8d4d-55e9bce61444/7071e302-8d5a-4127-8d4d-55e9bce61444_540x304.jpg 540w, https://media.wtsp.com/assets/WTSP/images/7071e302-8d5a-4127-8d4d-55e9bce61444/7071e302-8d5a-4127-8d4d-55e9bce61444_750x422.jpg 750w, https://media.wtsp.com/assets/WTSP/images/7071e302-8d5a-4127-8d4d-55e9bce61444/7071e302-8d5a-4127-8d4d-55e9bce61444_1140x641.jpg 1140w, https://media.wtsp.com/assets/WTSP/images/7071e302-8d5a-4127-8d4d-55e9bce61444/7071e302-8d5a-4127-8d4d-55e9bce61444_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/video/weather/10-weather-sunshine-and-70s-for-sunday/67-f493e88b-c767-4c9d-aca1-3786ee5e0363" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; 10 Weather: Sunshine and 70s for Sunday">10 Weather: Sunshine and 70s for Sunday</a></h4>
                                            </div>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_false" href="/near-me" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Near Me">
                                        <span class="header__nav-label">Near Me</span>
                            </a>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_false" href="/verify" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="VERIFY">
                                        <span class="header__nav-label">VERIFY</span>
                            </a>
                        </li>
                        <li>
                            <div class="header__mini-live-video">
<div data-module="watch-live" class="watch-live watch-live_active_false" data-watch-enabled="true">
    <a class="watch-live__cta" href="/watch">
        <span class="watch-live__label">Watch</span>
    </a>
    <div class="watch-live__mini-live-video watch-live__mini-live-video_active_false">
        <a class="watch-live__video-link" href="/watch">
    <div data-module="mini-live-video" class="mini-live-video mini-live-video_state_stopped" data-is-watch="false">    
        <div class="mini-live-video__player"></div>
    </div>        </a>
    </div>
</div>                            </div>
                        </li>
                    <li class="header__nav-search header__nav-search_type_search">
                        <a class="header__nav-link header__nav-link_type_search" href="/search">
                            <label class="header__nav-label header__nav-label_type_search" for="site_search">Search</label>
                        </a>
                        <div class="header__subnav header__subnav_type_search">
                            <div class="header__subnav-group header__subnav-group_name_search">
                                <form class="header__search-form" method="GET" action="/search">
                                    <label class="header__search-label" for="site_search">Search:</label>
                                    <input class="header__search-box" placeholder="Search wtsp.com" id="site_search" type="search" name="q" />
                                    <button class="header__search-submit" type="submit">Search</button>
                                </form>
                            </div>
                            <button class="header__close-button" aria-label="close"></button>
                        </div>
                    </li>
                </ul>
                    <div class="header__sponsor">
        <div data-module="ad" class="ad ad_position_masthead_sponsor ad_background_false"
         data-status="new"
         data-path="/32805352/fl-tampa-WTSP-B3313_DesktopTablet/masthead_sponsor/news/entertainment-news"
         data-sizes="[[112,38]]"
         data-delay="0"
         data-position="masthead_sponsor"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id="4204204272"
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_false" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                    </div>
                <a class="header__weather-link" href="/weather" data-tracking-action="weather-summary/weatherClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c">
                    <div class="header__weather">
                        <div class="header__weather-desktop-info">
                            <div class="header__weather-label header__weather-label_alerts_true">Right Now</div>
                            <div class="header__weather-city header__weather-city_alerts_true">Tampa, FL&nbsp;&raquo;</div>
                        </div>
                        <div class="header__weather-content">
                            <div class="header__weather-info header__weather-info_alerts_true">
                                <div class="header__weather-temp header__weather-temp_alerts_true">65&deg;</div>

                                <div class="header__weather-icon header__weather-icon_alerts_true">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-97_8x8.png" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/backgrounds/blank.png" data-src="/assets/shared-images/weather-icons/wx-97_32x32.png" data-srcset="/assets/shared-images/weather-icons/wx-97_8x8.png 8w, /assets/shared-images/weather-icons/wx-97_16x16.png 16w, /assets/shared-images/weather-icons/wx-97_32x32.png 32w, /assets/shared-images/weather-icons/wx-97_64x64.png 64w, /assets/shared-images/weather-icons/wx-97_128x128.png 128w, /assets/shared-images/weather-icons/wx-97_210x210.png 210w" sizes="26px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-97_32x32.png" srcset="/assets/shared-images/weather-icons/wx-97_8x8.png 8w, /assets/shared-images/weather-icons/wx-97_16x16.png 16w, /assets/shared-images/weather-icons/wx-97_32x32.png 32w, /assets/shared-images/weather-icons/wx-97_64x64.png 64w, /assets/shared-images/weather-icons/wx-97_128x128.png 128w, /assets/shared-images/weather-icons/wx-97_210x210.png 210w" sizes="26px" loading="lazy" /></noscript></div>
                                </div>
                            </div>
                            <div class="header__weather-city header__weather-city_alerts_true">Tampa, FL&nbsp;&raquo;</div>
                        </div>
                    </div>
                </a>
            <div class="header__alerts">
                    <a class="header__alert header__alert_type_weather header__alert_visible_true" href="/weather/alerts" data-tracking-action="weatheralert/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c">Weather</a>
                    <a class="header__alert header__alert_type_closings header__alert_visible_false" href="/closings" data-tracking-action="closingsalert/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c">Closings</a>
            </div>
            </nav>
        </div>
    </div>
    <div class="header__featured">
            <div class="header__featured-arrow header__featured-arrow_direction_previous"><img src="/images/header/arrow.png" width="14" height="14" loading="eager" alt="" /></div>
            <div class="header__featured-inner">
                <ul class="header__featured-list">
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/advertise">Advertise With Us</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/tropics">Hurricane Headquarters</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/brightside">Brightside</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/10-investigates">10 Investigates</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/connect">Connect</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/great-day-live">Great Day Live</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/foreverfamily">Forever Family</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/section/beyond-the-headline">Beyond The Headline</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/heartthreads">HeartThreads</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/section/got-a-minute">Got a Minute</a>
                        </li>
                </ul>
            </div>
            <div class="header__featured-arrow header__featured-arrow_direction_next"><img src="/images/header/arrow.png" width="14" height="14" loading="eager" alt="" /></div>
    </div>
</header>            </div>
            <div class="page__dock">
                    <div class="page__breaking-news-alerts">
    <div data-module="breaking-news-alerts" class="breaking-news-alerts breaking-news-alerts_visible_false">
        <div class="breaking-news-alerts__wrap">
            <div class="breaking-news-alerts__close"></div>
            <div class="breaking-news-alerts__label">Breaking News</div>
            <ul class="breaking-news-alerts__headline-wrap">
                <template class="breaking-news-alerts__template">
                    <li class="breaking-news-alerts__item">
                        <a class="breaking-news-alerts__link" href="#" data-tracking="breaking-news-alerts/linkClicked">
                            <span class="breaking-news-alerts__headline"></span>
                            <span class="breaking-news-alerts__read-more">Read More &raquo;</span>
                        </a>
                    </li>
                </template>
            </ul>
            <a class="breaking-news-alerts__more" href="/breaking-news" data-tracking="breaking-news-alerts/moreClicked">More (<span class="breaking-news-alerts__count"></span>) &raquo;</a>
        </div>
    </div>
                    </div>
            </div>
        <main class="page__main" id="main">
            <div class="page__grid">
                


    <div data-module="grid" class="grid grid_version_2-1">
        <div class="grid__section grid__section_theme_default" data-theme="default">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_right grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_2" data-columns="2">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_article" data-module-sizer="article" data-count="1">
<article class="article" data-module="article"
         data-article-id="60112934-7fa9-4fff-a304-8668bfd4b11c"
         data-title="From Tampa Bay to Hollywood: South St. Pete native Will Packer producing Sunday&#x2019;s Oscars"
         data-seo-title="St. Pete native Will Packer co-producing this year&#x27;s Oscars"
         data-abstract="Known for films like Girls Trip and Straight Outta Compton, the St. Pete High School graduate will be one half of the Oscars&#x2019; first all-Black producing team."
         data-section="news"
         data-subsection="entertainment-news"
         data-topic=""
         data-subtopic=""
         data-url="www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c"
         data-gpt-network-code="32805352"
         data-categories="entertainment-news,news,nation-world,home"
         data-author="Emerald Morrow"
         data-keywords="entertainment-news,news,nation-world,home"
         data-has-video="true"
         data-watson-keywords="South St. Pete,Tampa Bay,St. Pete High School graduate,native Will Packer,Tampa Bay&#x2019;s Emerald Morrow"
         data-t1-publisher="jhighsmith@tegna.com"
         data-is-cct="false"
         data-original-headline="From Tampa Bay to Hollywood: South St. Pete native Will Packer producing Sunday&#x2019;s Oscars"
         data-content-score="85"
         data-tracking-tags="">
        <a class="article__category" href="/section/entertainment-news" data-tracking-category="article" data-tracking-action="click" data-tracking-label="article; topic; Entertainment News">Entertainment News</a>
        <h1 class="article__headline">From Tampa Bay to Hollywood: South St. Pete native Will Packer producing Sunday&#x2019;s Oscars</h1>
        <div class="article__summary">Known for films like Girls Trip and Straight Outta Compton, the St. Pete High School graduate will be one half of the Oscars’ first all-Black producing team.</div>
        <div class="article__lead-asset">
        <div data-module="video" class="video"
             data-stream="https://video.tegna-media.com/assets/WTSP/videos/b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4/b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4.m3u8"
             data-float="true"
             data-thumbnail="https://media.wtsp.com/assets/WTSP/images/d114c68c-8bcf-4f3d-8c79-f4126172e41a/d114c68c-8bcf-4f3d-8c79-f4126172e41a_1920x1080.jpg"
             data-title="South St. Pete native Will Packer producing Sunday&#x2019;s Oscars"
             data-description="Known for films like Girls Trip and Straight Outta Compton, the St. Pete High School graduate will be one half of the Oscars&#x2019; first all-Black producing team."
             data-site="67"
             data-id="b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4"
             data-mute="false"
             data-autoplay="true"
             data-link="https://www.wtsp.com/video/news/local/south-st-pete-native-will-packer-producing-sundays-oscars/67-b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4"
             data-origin="clipping"
             data-section="news"
             data-subsection="local"
             data-subcategory="local"
             data-topic=""
             data-subtopic=""
             data-categories="local,entertainment-news,nation-world,news"
             data-captions="https://video.tegna-media.com/assets/WTSP/videos/b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4/b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4_vtt.vtt"
             data-tracking-tags=""
             data-is-watch-player="false"
             data-is-live-now="VOD"
             data-is-ugc="false"
             data-is-cct="false"
             data-ugc-preroll-disabled="true"
             data-duration="138"
             data-disable-preroll-at-duration="0"
             data-disable-preroll="false"
             data-publica-id="9336"
             data-media-tailor-enabled="true"
             data-newscast-preroll-disabled="false"
             data-facebook-app-id="1997344770552980"
             data-sharing-twitter-title="South%20St.%20Pete%20native%20Will%20Packer%20producing%20Sunday%E2%80%99s%20Oscars"
             data-sharing-twitter-username="10TampaBay"
             data-a9-pubid="3276">
            <div class="video__ratio-enforcer">
                <div class="video__ratio-enforced">
                    <div class="video__docker-container">
                        <div class="video__docker">
                            <button class="video__docker-close" aria-label="undock video"></button>
                            <div class="video__ratio-enforcer">
                                <div class="video__ratio-enforced">
                                    <div class="video__inner">
                                        <div class="video__player-container">
                                            <div class="video__player"></div>
                                        </div>
                                    </div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
                                            <script type="application/ld+json">
                    {
                    "@context": "http://schema.org",
                    "@type": "VideoObject",
                    "name": "South St. Pete native Will Packer producing Sunday&#x2019;s Oscars",
                    "description": "Known for films like Girls Trip and Straight Outta Compton, the St. Pete High School graduate will be one half of the Oscars&#x2019; first all-Black producing team.",
                    "thumbnailUrl": "https://media.wtsp.com/assets/WTSP/images/d114c68c-8bcf-4f3d-8c79-f4126172e41a/d114c68c-8bcf-4f3d-8c79-f4126172e41a_1920x1080.jpg",
                    "uploadDate": "3/26/2022 11:37:31 PM",
                    "duration": "138",
                    "contentUrl": "https://www.wtsp.com/video/news/local/south-st-pete-native-will-packer-producing-sundays-oscars/67-b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4",
                    "embedUrl": "https://media.wtsp.com/embeds/video/67-b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4/iframe"
                    }
                        </script>
                </div>
        </div>
        <aside class="article__meta">
                <div class="article__author">
                    <span class="article__meta-label">Author:</span> Emerald Morrow
                </div>
                <div class="article__published">
                    <span class="article__meta-label">Published:</span> 11:17 PM EDT March 26, 2022
                </div>
                <div class="article__updated">
                    <span class="article__meta-label">Updated:</span> 11:43 PM EDT March 26, 2022
                </div>
    <div data-module="article-sharing" class="article-sharing">
        <a class="article-sharing__icon" href="https://www.facebook.com/dialog/share?app_id=1997344770552980&display=popup&href=https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c&redirect_uri=https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c" target="_blank" data-tracking-action="sharing/facebookLink" data-tracking-category="link click" data-tracking-label="Link From: https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c">
            <img class="article-sharing__logo" alt="Facebook" src="/assets/shared-images/icons/facebook.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
        <a class="article-sharing__icon" href="https://twitter.com/intent/tweet?text=From%20Tampa%20Bay%20to%20Hollywood:%20South%20St.%20Pete%20native%20Will%20Packer%20producing%20Sunday%E2%80%99s%20Oscars&url=https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c&via=10TampaBay" target="_blank" data-tracking-action="sharing/twitterLink" data-tracking-category="link click" data-tracking-label="Link From: https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c">
            <img class="article-sharing__logo" alt="Twitter" src="/assets/shared-images/icons/twitter.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
    </div>        </aside>
    <div class="article__body">
                    <div class="article__section article__section_type_text utility__text">
<p>TAMPA, Fla. — Where there’s a Will, there’s a way.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>That line works especially well when you’re Will Packer, a south St. Petersburg native making history this weekend as he produces the 94th Academy Awards.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Known for films like Girls Trip and Straight Outta Compton, the 1991 St. Petersburg High School graduate will be one half of the Oscars’ first all-Black producing team.</p>                    </div>
                        <div class="article__section article__section_type_ad">
        <div data-module="ad" class="ad ad_position_article_mid1 ad_background_true"
         data-status="new"
         data-path="/32805352/fl-tampa-WTSP-B3313_DesktopTablet/article_mid1/news/entertainment-news"
         data-sizes="[[300,250],[1,1],[750,570],[1,2]]"
         data-delay="8"
         data-position="article_mid1"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id="1420432751"
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id="4204204272"
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                        </div>
                    <div class="article__section article__section_type_text utility__text">
<p>10 Tampa Bay’s Emerald Morrow spoke to the filmmaker ahead of his big night.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><em>NOTE: This conversation has been edited for clarity and length.</em></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Emerald Morrow, 10 Tampa Bay: You're at the helm of Hollywood's biggest night. What does this moment mean to you as a St. Petersburg native?</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Will Packer, producer: I am doing a lot of these interviews talking to a lot of press. I love it. That's all part of the process — it's nothing like talking to home. I will tell you that this is definitely special. To be a young man grew up there in St. Pete, product of the ‘Burg, you know, the Tampa Bay community and to be here, you know, helming Hollywood's biggest night. It's quite an honor. It means everything.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Reporter: How did your time in St. Petersburg and at FAMU influence you?</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Packer: Oh, there's no question here. Listen, I learned focus. I learned tenacity, I learned ambition. You know, I was…a product of the public school system. Even in high school, I was always very competitive. I was Mr. St. Pete high school and student body president and active in all these different organizations and clubs. And the same thing is true when I went to FAMU. I continued to kind of find my voice and hone my skills, and so my upbringing in Florida…1,000 percent it has helped create the person I am today.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><strong class="cms__embed-related-story">RELATED: <a class="cms__embed-related-story__link" href="/article/entertainment/beyonce-2022-oscars-st-pete-native/67-3ae9e121-a19b-4d7a-879d-e7e453959ee7">Beyonce set to perform at 2022 Oscars produced by St. Pete native</a></strong></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Reporter: Producing The Oscars is a massive project. What have these last several months been like for you?</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Packer: Oh my God…I produce movies and television all the time. This project – this is like producing 10 movies at once. That's what it's like. It is extremely arduous, very labor-intensive. It's so much scrutiny is on the Oscars, right? Everybody has an opinion about the Oscars…I got an opinion, too this year. It'll be my opinion, and my perspective, and my vision that you'll see on the screen. I just hope people watch it, have a good time. I want to be fun. I want to be celebratory. That's what I'm looking forward to.</p>                    </div>
                                <div class="article__section article__section_type_ad">
        <div data-module="ad" class="ad ad_position_article_mid2 ad_background_true"
         data-status="new"
         data-path="/32805352/fl-tampa-WTSP-B3313_DesktopTablet/article_mid2/news/entertainment-news"
         data-sizes="[[300,250],[1,1]]"
         data-delay="8"
         data-position="article_mid2"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey="[&#xD;&#xA;  &quot;2YNEkKMk1QC5WsCndTXLDYVB&quot;&#xD;&#xA;]"
         data-collapse="false"
         data-ozone-placement-id="1420432752"
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id="4204204272"
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Reporter: Tell me a little bit more about your approach to this year's Oscars. What are we going to see that's going to specifically have Will Packer’s touch?</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Packer: One thing I have to tell you is that I felt like the Oscars for too long have felt like it's just this kind of…insider event and not an entertainment event for movie lovers everywhere. It felt like it was for Hollywood, by Hollywood… But that's not how I feel like we should be approaching this.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>You’ll see entertainment value in the show, throughout the show. We are going to have music on the show. We are going to have people that aren't in the movie industry, but are movie-lovers be a part of the show as well.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>I wanted to be a show that whether or not you're somebody that watches all the Oscar-nominated movies every year.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Reporter: This moment for you and Shayla Cowen as the first African American duo co-producing Oscars is huge, and a far cry from the Oscars boycott and #OscarsSoWhite hashtag we saw several years back. What is the importance of diversity in The Academy, and the importance of this role that you are taking on?</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Packer: Imagery matters. Optics matter. Representation matters…For us to be the first all-black producing team to handle Hollywood's biggest night—it's big, it's huge. Somebody will see that. Somebody will watch this interview, who grew up like I grew up and will say, ‘You know what, I don't have the Hollywood pedigree. You know, I look like Will Packer more than I look like some of the other folks who have traditionally run Hollywood, but Will Packer can do it, we can do it. That's what I want.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>It's obviously not just about this. This is a night for everybody, but I'm proud of the fact that it is our differences and embracing the differences and embracing folks from communities that haven't always had a voice, that haven't always had a seat at the table. Bringing us all in makes us stronger.</p>                    </div>
                                <div class="article__section article__section_type_ad">
        <div data-module="ad" class="ad ad_position_article_mid3 ad_background_true"
         data-status="new"
         data-path="/32805352/fl-tampa-WTSP-B3313_DesktopTablet/article_mid3/news/entertainment-news"
         data-sizes="[[300,250]]"
         data-delay="8"
         data-position="article_mid3"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id="1420432753"
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id="4204204272"
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 250px; min-width: 300px;">
        </div>
    </div>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Reporter: Anything you want to say to anybody here in St. Petersburg, particularly to those young people that you mentioned, who may be watching this and may not know the path to get where you are?</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Packer: Keep working and keep working hard. That's the thing. Your hard work will pay off. I sat right where you're sitting, and I'm very happy, very honored and very blessed to sit in the seat that I sit now. Everybody starts someplace, and I didn't have a lot of Hollywood connections. I still don't consider myself a Hollywood Insider. That doesn't matter. Because when it was time for me to go to work, I worked hard and I don't care if that was at Maximo Elementary School, Bay Point Middle, or St. Pete High School. I put the work in and it paid off. That's what I would encourage my young people to do.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><strong class="cms__embed-related-story">RELATED: <a class="cms__embed-related-story__link" href="/article/entertainment/events/oscars/2022-oscars-academy-awards/507-a36fea18-1cb6-4d50-af64-a8dc93b1294b">Who is presenting at the 2022 Oscars?</a></strong></p>                    </div>
                                <div class="article__section article__section_type_embed">
                                    <div style="left: 0; width: 100%; height: 0; position: relative; padding-bottom: 56.25%;"><iframe src="https://www.youtube.com/embed/hTAV51DGV5E?rel=0" style="border: 0; top: 0; left: 0; width: 100%; height: 100%; position: absolute;" allowfullscreen scrolling="no" allow="encrypted-media; accelerometer; clipboard-write; gyroscope; picture-in-picture"></iframe></div>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Reporter: Any last words before the show?</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Packer: Y'all tune in. Don't miss the opening. Get there on time. Tune in watch it. It's gonna be a fun night.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>For those looking for a place to dress up and watch the show, the Tampa Theatre is hosting its 23rd "<a href="https://www.etix.com/ticket/p/5138970/2022-hollywood-awards-night-tampa-tampa-theatre">Hollywood Awards Night</a>" complete with a limo ride, red carpet and "paparazzi." Tickets start at $25.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>St. Pete Mayor Ken Welch is also hosting a watch party in partnership with the Carter G. Woodson Museum at 2240 9th Avenue S. Doors open at 7 p.m.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a name="_Hlk3315794"><strong><em>Emerald Morrow is a reporter with</em></strong></a><em>&nbsp;</em><strong><em>10News</em></strong><em>&nbsp;</em><strong><em>WTSP. Like her on</em></strong><em>&nbsp;</em><a href="http://www.facebook.com/emeraldmorrowWTSP" target="_blank"><strong><em>Facebook</em></strong></a><em>&nbsp;</em><strong><em>and follow her on</em></strong> <a href="http://www.twitter.com/emeraldmorrow" target="_blank"><strong><em>Twitter</em></strong></a><strong><em>. You can also email her at</em></strong><em>&nbsp;</em><a href="mailto:emorrow@wtsp.com?subject=Hi%2C%20Emerald!"><strong><em>emorrow@wtsp.com</em></strong></a><strong><em>.</em></strong></p>                    </div>
    </div>
    <script type="application/ld+json">
        {
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "headline": "From Tampa Bay to Hollywood: South St. Pete native Will Packer producing Sunday’s Oscars",
  "datePublished": "11:17 PM EDT March 26, 2022",
  "dateModified": "11:43 PM EDT March 26, 2022",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.wtsp.com/article/news/entertainment-news/who-is-producer-producing-oscars-st-pete-florida/67-60112934-7fa9-4fff-a304-8668bfd4b11c"
  },
  "author": {
    "@type": "Person",
    "name": "Emerald Morrow"
  },
  "publisher": {
    "@type": "Organization",
    "name": "WTSP",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.wtsp.com/assets/shared-images/amp-logos/wtsp.png",
      "width": 340,
      "height": 60
    }
  }
}
    </script>
</article>                                    </div>
                                </div>
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_taboola" data-module-sizer="taboola" data-count="1">
    <div data-module="taboola" class="taboola" id="taboola-below-article-thumbnails-2nd-::articleNumber::"
         data-page-type="article"
         data-ad="below_taboola"
         data-mode="thumbnails-h2"
         data-target-type="mix"
         data-placement="Below Article Thumbnails 2nd"
         data-url="http://www.wtsp.com::contentUrl::"
         data-id="taboola-below-article-thumbnails-2nd-::articleNumber::">
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

                    <div class="grid__sticky-column grid__sticky-column_side_right">
                        <div class="grid__sticky-content" data-columns="1">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
        <div data-module="ad" class="ad ad_position_article_atf ad_background_true"
         data-status="new"
         data-path="/32805352/fl-tampa-WTSP-B3313_DesktopTablet/article_atf/news/entertainment-news"
         data-sizes="[[300,250]]"
         data-delay="8"
         data-position="article_atf"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id="1420432749"
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id="4204204272"
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 250px; min-width: 300px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/fl-tampa-WTSP-B3313_DesktopTablet/article_atf/news/entertainment-news&amp;sz=300x250&amp;c=869" width="300" height="250" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_related-videos" data-module-sizer="related-videos" data-count="1">
    <div data-module="related-videos" class="related-videos">
        <div class="related-videos__player">
        <div data-module="video" class="video"
             data-stream="https://video.tegna-media.com/assets/WTSP/videos/b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4/b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4.m3u8"
             data-float="false"
             data-thumbnail="https://media.wtsp.com/assets/WTSP/images/d114c68c-8bcf-4f3d-8c79-f4126172e41a/d114c68c-8bcf-4f3d-8c79-f4126172e41a_1920x1080.jpg"
             data-title="South St. Pete native Will Packer producing Sunday&#x2019;s Oscars"
             data-description="Known for films like Girls Trip and Straight Outta Compton, the St. Pete High School graduate will be one half of the Oscars&#x2019; first all-Black producing team."
             data-site="67"
             data-id="b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4"
             data-mute="true"
             data-autoplay="true"
             data-link="https://www.wtsp.com/video/news/local/south-st-pete-native-will-packer-producing-sundays-oscars/67-b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4"
             data-origin="video"
             data-section="news"
             data-subsection="local"
             data-subcategory="local"
             data-topic=""
             data-subtopic=""
             data-categories="local,entertainment-news,nation-world,news"
             data-captions=""
             data-tracking-tags=""
             data-is-watch-player="false"
             data-is-live-now="VOD"
             data-is-ugc="false"
             data-is-cct="false"
             data-ugc-preroll-disabled="true"
             data-duration=""
             data-disable-preroll-at-duration="0"
             data-disable-preroll="false"
             data-publica-id="9336"
             data-media-tailor-enabled="true"
             data-newscast-preroll-disabled="false"
             data-facebook-app-id="1997344770552980"
             data-sharing-twitter-title="South%20St.%20Pete%20native%20Will%20Packer%20producing%20Sunday%E2%80%99s%20Oscars"
             data-sharing-twitter-username="10TampaBay"
             data-a9-pubid="3276">
            <div class="video__ratio-enforcer">
                <div class="video__ratio-enforced">
                    <div class="video__docker-container">
                        <div class="video__docker">
                            <button class="video__docker-close" aria-label="undock video"></button>
                            <div class="video__ratio-enforcer">
                                <div class="video__ratio-enforced">
                                    <div class="video__inner">
                                        <div class="video__player-container">
                                            <div class="video__player"></div>
                                        </div>
                                    </div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
                                            <script type="application/ld+json">
                    {
                    "@context": "http://schema.org",
                    "@type": "VideoObject",
                    "name": "South St. Pete native Will Packer producing Sunday&#x2019;s Oscars",
                    "description": "Known for films like Girls Trip and Straight Outta Compton, the St. Pete High School graduate will be one half of the Oscars&#x2019; first all-Black producing team.",
                    "thumbnailUrl": "https://media.wtsp.com/assets/WTSP/images/d114c68c-8bcf-4f3d-8c79-f4126172e41a/d114c68c-8bcf-4f3d-8c79-f4126172e41a_1920x1080.jpg",
                    "uploadDate": "11:37 PM EDT March 26, 2022",
                    "duration": "",
                    "contentUrl": "https://www.wtsp.com/video/news/local/south-st-pete-native-will-packer-producing-sundays-oscars/67-b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4",
                    "embedUrl": "https://media.wtsp.com/embeds/video/67-b48e6a53-3bfd-40f5-bc7c-d7c7d5c77af4/iframe"
                    }
                        </script>
                </div>
        </div>
        <p class="related-videos__topic">In Other News</p>
        <h4 class="related-videos__title">South St. Pete native Will Packer producing Sunday&#x2019;s Oscars</h4>
    </div>
                                    </div>
                                </div>
                        </div>
                    </div>
            </div>
        </div>
        <div class="grid__section grid__section_theme_default" data-theme="default">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
        <div data-module="ad" class="ad ad_position_article_flex_btf ad_background_true"
         data-status="new"
         data-path="/32805352/fl-tampa-WTSP-B3313_DesktopTablet/article_flex_btf/news/entertainment-news"
         data-sizes="[[970,250],[728,90],[1140,286],[1,1]]"
         data-delay="8"
         data-position="article_flex_btf"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id="1420432750"
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id="4204204272"
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/fl-tampa-WTSP-B3313_DesktopTablet/article_flex_btf/news/entertainment-news&amp;sz=970x250|728x90|1140x286|1x1&amp;c=870" width="1140" height="286" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
        <div class="grid__section grid__section_theme_default" data-theme="default">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_article-loader" data-module-sizer="article-loader" data-count="1">

<div class="article-loader" data-module="article-loader">
    <button class="article-loader__button"></button>
</div>                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
    </div>

            </div>
        </main>
            <div class="page__footer page__footer_theme_default">
<footer data-module="footer" class="footer">
    <div class="footer__outer">
        <div class="footer__inner">
            <div class="footer__logo-wrap">
                <img class="footer__logo" alt="WTSP-TV" src="/assets/shared-images/logos/wtsp.png">
            </div>
            <div class="footer__menu">
                    <ul class="footer__list">
                                <li class="footer__item"><a class="footer__link" href="https://www.wtsp.com/wtspjobs" target="_blank" rel="noopener">Jobs</a></li>
                                <li class="footer__item"><a class="footer__link" href="/terms" target="_self" rel="">Terms of Service</a></li>
                                <li class="footer__item"><a class="footer__link" href="/privacy" target="_self" rel="">Privacy Policy</a></li>
                                <li class="footer__item"><a class="footer__link" href="/adchoices" target="_self" rel="">Ad Choices</a></li>
                    </ul>
                    <ul class="footer__list">
                                <li class="footer__item"><a class="footer__link" href="https://interactive.wtsp.com/pdfs/PublicFileReport.pdf" target="_blank" rel="noopener">EEO Public File Report</a></li>
                                <li class="footer__item"><a class="footer__link" href="/fcc-public-inspection-file" target="_self" rel="">FCC Online Public Inspection File</a></li>
                                <li class="footer__item"><a class="footer__link" href="/closed-captioning" target="_self" rel="">Closed Caption Procedures</a></li>
                                <li class="footer__item footer__item_visible_false"><a class="footer__link footer__link_behavior_show-consent-options" target="_self" href="/do-not-sell-my-information">Do Not Sell My Personal Information</a></li>
                    </ul>
            </div>
            <div class="footer__copyright">
                &copy; 2022 WTSP-TV. All Rights Reserved.
            </div>
        </div>
    </div>
</footer>            </div>
    </div>
        <div class="page__interstitial">
        <div data-module="ad" class="ad ad_position_exit_interstitial ad_background_true"
         data-status="new"
         data-path="/32805352/fl-tampa-WTSP-B3313_DesktopTablet/exit_interstitial/news/entertainment-news"
         data-sizes="[[1,1]]"
         data-delay="8"
         data-position="exit_interstitial"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id="4204204272"
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
        <div class="page__notifications">

<div data-module="notifications" class="notifications" style="display:none">
    <div class="notifications__logo-container">
        <img class="notifications__logo" alt="WTSP" src="/assets/shared-images/logos/wtsp.png" />
    </div>
    <h2 class="notifications__heading">WTSP would like to send you push notifications about the latest news and weather.</h2>
    <p class="notifications__description">Notifications can be turned off anytime in the browser settings.</p>
    <div class="notifications__buttons">
        <button class="notifications__button notifications__button_option_no notifications__button_default_false">No Thanks</button>
        <button class="notifications__button notifications__button_option_yes notifications__button_default_true">Allow</button>
    </div>
</div>
        </div>
        <div class="page__toasts">

<div class="toasts">
    <script class="toasts__toast-template" type="text/template">
        <div class="toasts__toast toasts__toast_new_true">
            <div class="toasts__logo-container">
                <img class="toasts__logo" src="/assets/shared-images/logos/wtsp.png" />
            </div>
            <div class="toasts__close">×</div>
            <div class="toasts__content">
                <div class="toasts__title"></div>
                <div class="toasts__body"></div>
                <p class="toasts__link">Read More</p>
            </div>
        </div>
    </script>
</div>        </div>
<div class="modal modal_open_false" data-theme="modal">
    <button class="modal__close-button" aria-label="close"></button>
    <div class="modal__content"></div>
</div>    <script src="https://amp.akamaized.net/hosted/1.1/player.esi?apikey=tegna&version=9.1.5"></script>
    <script>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</script>
    <script data-base="/" data-modules="accessibility-statement,ad,adchoices,all-alerts,app-badge,app-promo-link,article,article-loader,article-sharing,article-verify-claim,article-verify-follow-subscribe,breaking-news-alerts,breaking-news-list,carousel,chapter-slider,closings,countdown,datasphere,datasphere-ad-article,datasphere-ad-front,election-single-race,elections,error,footer,from-you,gallery,grid,header,headline-list,hot-races,hot-races-carousel,hourly-graph,iframe,lazy-image,live-broadcasts,live-video-banner,longform,mini-live-video,modal,nbc-olympics-live-streams,nbc-olympics-medals-count,nbc-olympics-tv-schedule,newsletter-signup,notifications,olympics-medal-count,page,personal-info,photo,pollen,privacy,radar-gallery,raw-html,related-stories,related-videos,right-now-hourly,right-now-radar,search,story,story-list,story-row,taboola,toasts,tos,ugc-cta,universal-ad,video,watch-carousel,watch-live,watch-secondary-content,weather-10-day,weather-alerts-list,weather-front-link,weather-hourly,weather-interactive-radar,weather-maps,weather-nav" data-version="6.2.1">!function(){if(window.tegna.supportsJavascript){var e=document.currentScript.dataset.modules.split(","),s=["page","photo","lazy-image","ad","gallery","video","taboola","related-stories","raw-html","elections","election-single-race"];for(var a=document.querySelectorAll("[data-module]"),t=0;t<a.length;++t)n=void 0,function(e,s){for(var a=s.length,t=0;t<a;t++)if(s[t]===e)return 1}(n=a[t].getAttribute("data-module"),s)||s.push(n);var r=document.currentScript.dataset.version,i=document.currentScript.dataset.base,l=document.getElementsByClassName("page")[0]?document.getElementsByClassName("page")[0].dataset.tealiumUrl:"";const o={utils:"tegna-utils_"+r,bem:"bem_"+r,"jquery-utils":"jquery-utils_"+r,storage:"tegna-storage_"+r,common:"common.min_"+r,swiper:"assets/js-libs/swiper/swiper.min","live-messages":"assets/js-libs/live-messages/live-messages",luxon:"assets/js-libs/luxon/luxon.min",tealium:l,signalr:"assets/js-libs/signalr/signalr.min",hls:"https://amp.akamaized.net/players/9.0.13+premier/akamai/amp/core/libs/hls.min",comscore:"assets/js-libs/comscore/comscore.min",places:"//maps.googleapis.com/maps/api/js?key=AIzaSyBEGr3U4E-OGcjwkhiXfqxfuvOqDQ7Z96c&libraries=places","@firebase/app":"firebase-app","@firebase/messaging":"firebase-messaging"};e.forEach(e=>{e in o==!1&&(o[e]=`${e}_${r}`)}),require.config({baseUrl:i,waitSeconds:30,bundles:{common:["page","universal-ad","header","footer","grid","breaking-news-alerts","tegna-utils","tegna-storage","tegna-tracking","header-updater"]},paths:o,shim:{swiper:{exports:"Swiper"},signalr:{exports:"signalR"},tealium:["jquery"]}}),s.forEach(s=>{try{require([s])}catch(e){void 0}})}var n}();
//# sourceMappingURL=configure-require.js.map</script>
        <script data-api-key="AIzaSyBBmYGZEvPcCmX9SFdhqfZDxbUqDaj5AtU" data-project-id="wtsp-news-app" data-sender-id="204712096697" data-app-id="1:204712096697:web:d1ff2e228ff65eb0">!function(){var e,a,i,p,t;window.tegna.supportsJavascript&&(e=document.currentScript.dataset,a=e.apiKey,i=e.projectId,p=e.senderId,t=e.appid,require(["@firebase/app","@firebase/messaging"],function(e){e.initializeApp({apiKey:a,authDomain:`${i}.firebaseapp.com`,databaseURL:`https://${i}.firebaseio.com`,projectId:i,storageBucket:`${i}.appspot.com`,messagingSenderId:p,appId:t}),window.firebase=e}))}();
//# sourceMappingURL=firebase.js.map</script>
    <script>!function(){function e(){void 0;for(var e,t=document.getElementsByTagName("noscript"),n=0;n<t.length;n++){var o=t.item(n);o.outerHTML=(e=o.innerHTML,o=void 0,(o=document.createElement("textarea")).innerHTML=e,0===o.childNodes.length?"":o.childNodes[0].nodeValue)}}var t,n,o;window.tegna.supportsJavascript||(t=document.body,(n=document.createElement("div")).innerHTML='<div style="background-color:#c50000;font-family:sans-serif;color:#ffffff;text-align:center;"><h2 style="margin:0;padding:10px 0;">Your browser is not fully supported.</h2><p style="margin:0;padding: 10px 0;">For full feature support, please upgrade to a modern browser such as <a href="https://www.microsoft.com/en-us/edge" style="color:#ffffff;" target="_blank">Microsoft Edge</a>.</p></div>',t.insertBefore(n,t.firstChild),e(),o=window.setInterval(function(){document.getElementsByTagName("noscript").length?e():clearInterval(o)},500))}();
//# sourceMappingURL=old-browser.js.map</script>
    <script>tegna.performance.parsed = { time: performance.now() };</script>
    <script>window.performance.mark('tegna_dom_parsed');</script>
    <script>window.tegna = window.tegna || {}; window.tegna.loaded = true;</script>
</body>
</html>
